Document Signature Display Errors

Incident Report for Fountain

Resolved

We've resolved the issue that caused signatures to display incorrectly on some documents. The underlying causes have been fixed, and all new documents are now signing and rendering correctly. We're completing a final data cleanup to repair the small number of documents created while the issue was active; the vast majority have already been restored, and we expect the rest to be corrected shortly. If you still see a signature error on a specific document, please contact support and we'll prioritize it.
Posted Jul 21, 2026 - 17:14 PDT

Monitoring

The error has been identified and mitigated. Continuous monitoring is in place to verify no new cases emerge and to ensure the stability of document signature functionality.
Posted Jul 17, 2026 - 16:12 PDT

Identified

The root cause has been identified. The team is actively implementing mitigation measures to resolve the document signature display errors and to prevent further occurrences.
Posted Jul 17, 2026 - 11:43 PDT

Investigating

The team is currently investigating a critical issue affecting the display and visualization of digitally signed documents. Some users are unable to properly view certain signed documents due to signature validation or rendering errors.
Posted Jul 06, 2026 - 10:19 PDT