Incident Involving Dropbox Sign
Incident Report for Fountain
Resolved
Dropbox now considers this incident resolved. They’ve concluded that for those who received or signed a document through Dropbox Sign, email addresses and names were exposed. You can read more information on this incident here: https://sign.dropbox.com/blog/a-recent-security-incident-involving-dropbox-sign.
Posted Aug 06, 2024 - 09:05 PDT
Investigating
Fountain is currently addressing an incident involving a third-party service, Dropbox Sign (formerly known as HelloSign). We are actively collaborating with Dropbox to obtain comprehensive details about the incident. To ensure the safety of customer data, Fountain has promptly implemented all necessary corrective and preventive measures. For additional information, please refer to their official notification provided here: https://sign.dropbox.com/blog/a-recent-security-incident-involving-dropbox-sign
Posted May 02, 2024 - 13:24 PDT