E-Verify Intermittent Availability

Incident Report for Fountain

Resolved

E-Verify availability has returned to normal. All functionality is operational, and we have confirmed stable performance. We will continue to monitor, but no further impact is expected.
Posted Nov 19, 2025 - 08:22 PST

Update

We are investigating this issue and coordinating with Everify to come to a resolution.
Posted Nov 11, 2025 - 17:17 PST

Investigating

We are currently investigating this issue.
Posted Nov 11, 2025 - 17:16 PST
This incident affected: Integrations (Everify).