Slowness with Hire

Incident Report for Fountain

Resolved

This incident has been resolved.
Posted May 19, 2026 - 14:06 PDT

Monitoring

A fix has been implemented. Message Center should now be accessible again. We will continue to monitor.
Posted May 19, 2026 - 13:28 PDT

Identified

We are seeing a secondary impact on app.fountain.com, app.us-2.fountain.com and app.us-4.fountain.com. We are continuing to investigate.
Posted May 19, 2026 - 13:02 PDT

Monitoring

Normal performance should be restoring
Posted May 19, 2026 - 12:16 PDT

Identified

We have identified an issue with the release in Hire that is causing some slowness for some tenants.
Posted May 19, 2026 - 12:09 PDT