Application Form Issues

Incident Report for Fountain

Resolved

The issue affecting applicant submissions has been resolved. All services are now fully operational. Thank you for your patience and understanding while we worked to restore functionality.
Posted Jul 25, 2025 - 07:36 PDT

Identified

We have identified the issue affecting applicant submissions and are actively working to restore full functionality. We’ll provide another update as soon as we have more information. Thank you for your patience.
Posted Jul 25, 2025 - 07:19 PDT

Investigating

We are experiencing errors when applicants are attempting to apply. We are investigating a root cause and restoring functionality as soon as possible.
Posted Jul 25, 2025 - 06:09 PDT