Compliance Stage unable to load

Incident Report for Fountain

Resolved

This incident has been resolved.
Posted Jul 14, 2026 - 13:27 PDT

Identified

We've identified an issue in which Hire applicants are unable to load their compliance stages. We're fixing it now and expect it resolved soon.
Posted Jul 14, 2026 - 09:50 PDT