Service Disruption Due to Third-Party Provider Issues

Incident Report for Fountain

Resolved

Cloudflare's traffic engineering efforts have successfully mitigated the majority of congestion and packet drops.
Posted Jun 22, 2026 - 14:10 PDT

Monitoring

Some users may experience HTTP 520 and 522 errors due to issues with a third-party provider. We are actively monitoring the situation and will provide updates as they become available.
Posted Jun 22, 2026 - 10:08 PDT
This incident affected: Infrastructure Providers (Cloudflare Cloudflare Authoritative DNS).