Blank Landing Page

Incident Report for Fountain

Resolved

This incident has been mitigated in the release earlier today. The team is continuing to monitor for reports of this issue.
Posted Jul 15, 2026 - 20:16 PDT

Identified

The issue has been identified and the team is working on a fix. This issue only impacts a subset of our users. We expect this to be fixed tomorrow, in our next release.
Posted Jul 14, 2026 - 17:59 PDT

Investigating

We're aware that a subset of our users are receiving a blank page on the Fountain Hire platform. We're currently investigating this. As a workaround in the meantime, you can refresh the page and be taken to the desired content.
Posted Jul 14, 2026 - 13:42 PDT