Issue with I-9 center

Incident Report for Fountain

Resolved

The scheduled maintenance has been completed
Posted Jul 03, 2025 - 19:38 PDT

Monitoring

The scheduled maintenance has been completed and we are monitoring the services
Posted Jul 03, 2025 - 19:37 PDT

Identified

We will be undergoing scheduled maintenance during this time.
Posted Jul 03, 2025 - 19:02 PDT

Investigating

In order to better serve our customers, we will be performing internal maintenance which will result in downtime across our network on Monday July 14, 2025 8:00 PM – 8:30 PM MST. During this window, the I-9 form and W-4 form tasks, supported through our E-verify partner, WorkBright, will be unavailable to users. We apologize for any inconvenience this may cause. To ensure a seamless experience for applicants, those who are not currently in the I-9 Center will remain in their current status. Similarly, applicants within the I-9 Center will maintain their progress exactly as it was before the downtime. We are committed to making this process as smooth as possible and appreciate your understanding as we work to enhance our services.
Posted Jul 03, 2025 - 19:02 PDT
This incident affected: Worker Experience Platform (Worker Experience Platform).