Requesting Worker Portal Link by Email Fails

Incident Report for Fountain

Resolved

This incident has been resolved.
Posted Jul 31, 2026 - 11:05 PDT

Identified

Some workers are reporting difficulty requesting portal links via email. We've identified the cause of the issue and are working to repair it now
Posted Jul 31, 2026 - 10:32 PDT
This incident affected: Worker Experience Platform (Worker Experience Platform).