Dropbox Sign (formerly HelloSign) Service Outage
Incident Report for Fountain
Resolved
This incident has been resolved.
Posted Apr 08, 2024 - 08:33 PDT
Identified
Dropbox Sign (formerly HelloSign) is currently suffering an outage making editing or creating new templates and esignatures inoperable. They are aware of the issue and are currently working on a fix for their service.
Posted Apr 08, 2024 - 08:19 PDT
This incident affected: Integrations (Dropbox Sign, Fax, and Forms API callbacks from Dropbox Sign, Dropbox Sign, Fax, and Forms Send signature requests, Dropbox Sign, Fax, and Forms Embedded signing through Dropbox Sign).