Service Degradation: I-9 & W-4 Center Availability

Incident Report for Fountain

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 01:18 PST

Monitoring

We are currently observing issues accessing the I-9 and W-4 Centers. This appears to be caused by an upstream service disruption with our provider, Cloudflare.Our team is actively monitoring the situation and will provide updates as soon as they become available. We apologize for any inconvenience.
Posted Dec 05, 2025 - 01:13 PST
This incident affected: Worker Experience Platform (Worker Experience Platform).