The issue affecting the Worker Experience (WX) production environment has been mitigated. All services are now operating normally, and performance has returned to expected levels. We will continue to monitor the environment to ensure stability.
Posted Oct 29, 2025 - 14:15 PDT
Monitoring
The Worker Experience (WX) production environment is now operational, though some services may continue to experience performance degradation. The team has implemented mitigation steps and is monitoring the situation closely. We’ll provide another update once full performance is restored.
Posted Oct 29, 2025 - 14:10 PDT
Identified
We are currently investigating an outage affecting the Worker Experience (WX) production environment. Some services are delayed or unresponsive. The root cause has been identified, and our team is working on implementing a fix. We will provide updates as the situation progresses.
Posted Oct 29, 2025 - 13:44 PDT
This incident affected: Worker Experience Platform (Worker Experience Platform).